Status: PayU Europe

Merchant Panel Login Disruption

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 14:12 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2026 - 14:12 CEST

Investigating

Merchant Panel login is currently unavailable due to a DDoS attack. Our team is actively mitigating the issue and working to restore access as quickly as possible.
Posted Apr 02, 2026 - 13:36 CEST
This incident affected: Merchant Panel.