Status: PayU Europe

Problem at BLIK

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Nov 01, 2025 - 10:50 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 01, 2025 - 10:45 CET

Identified

on 01.11.2025 at 08:26 AM CET we have identified a problem at BLIK. Payments with BLIK are currently not available for PayU Europe integrations.

We are supporting the BLIK to handle this issue

We apologize for the inconvenience.
Posted Nov 01, 2025 - 08:49 CET
This incident affected: BLIK.