Status: PayU Europe

degradation at BLIK

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted May 29, 2025 - 12:06 CEST

Investigating

on 29.05.2025 from 11:49 PM CEST we have identified a problem at BLIK. Payments with BLIK are degraded for PayU Europe integrations. We are monitoring the situation.
Posted May 29, 2025 - 12:00 CEST
This incident affected: BLIK.