Status: PayU Europe

PayU system performance degradation

Incident Report for PayU Europe

Resolved

As of 21:20 CET problems were resolved
Posted Mar 01, 2026 - 21:30 CET

Update

We are continuing to investigate this issue.
Posted Mar 01, 2026 - 21:29 CET

Investigating

From 20:30 CET We are experiencing DDOS attack at the moment. We are working to limit the impact.
Customers might encounter:
- problems with logging to merchant panel
- longer authorisation times
- problems with accessing API
Posted Mar 01, 2026 - 21:17 CET
This incident affected: Platform availability and Merchant Panel.