We are continuing to monitor for any further issues.
Posted Feb 02, 2026 - 16:00 CET
Monitoring
We would like to inform you that we have implemented a series of changes designed to stabilize the current situation. Our team is actively monitoring the effects of these updates to ensure continued performance. We will provide further information as the situation evolves.
Posted Feb 02, 2026 - 15:30 CET
Update
Our team is continuing to work on mitigating the ongoing DDoS attack. We are currently observing an improvement in system stability.
Posted Feb 02, 2026 - 14:59 CET
Identified
We are currently experiencing a DDoS attack affecting our infrastructure. Our engineering team is actively implementing mitigation measures to restore full service. We apologize for any connectivity issues you may be experiencing.
Posted Feb 02, 2026 - 14:34 CET
Investigating
today, on 02.01.2026 from 2:00 PM CET we are facing a major technical problem. Please expect the following:
customers are not able to use payment methods (provided by PayU Europe),
customers are not able to check their payment status on the PayU page,
you are not able to log in to the PayU Management Panel.
We have immediately started working on resolving the issue