Status: PayU Europe
Problem with BLIK
Incident Report for PayU Europe
Resolved
today, on 02.08.2024 from 11:41 to 12:14 AM/PM CEST we faced a problem with BLIK payments. Payments with BLIK were temporarily degraded for PayU Europe integrations, but it is back to normal now.

We apologize for any inconvenience.
Posted Sep 02, 2024 - 12:17 CEST
Update
BLIK has confirmed the issue on their side.
Posted Sep 02, 2024 - 11:51 CEST
Identified
We have identified a problem on BLIK side. Payments with BLIK are currently degraded for PayU Europe integrations.

We are contacting BLIK to handle the issue.

We apologize for the inconvenience.
Posted Sep 02, 2024 - 11:43 CEST
This incident affected: BLIK.