Status: PayU Europe

System degradation

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 16:30 CEST

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 16:26 CEST

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 15:41 CEST

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 15:00 CEST

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 14:28 CEST

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 14:03 CEST

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 13:36 CEST

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 13:09 CEST

Investigating

We are currently experiencing severe system degradation affecting core services. Users may encounter slow performance, timeouts, or limited functionality. Our engineering team is actively investigating and working to restore normal operations as quickly as possible.
Posted Sep 04, 2025 - 12:55 CEST
This incident affected: Platform availability and Cards.