Status: PayU Europe

Degradation at BLIK

Incident Report for PayU Europe

Resolved

We have received information that one of the banks experienced an authorization issue with BLIK. As a result, it disabled BLIK code generation on its application side. Transaction conversion rate returned to normal levels at 22:48 CEST.
Posted Sep 27, 2025 - 23:10 CEST

Investigating

On 27.09.2025 from 22:10 CEST, we have observed an issue on BLIK’s side. BLIK payments are currently degraded for PayU Europe integrations. We are monitoring the situation closely and are in contact with BLIK.
Posted Sep 27, 2025 - 22:54 CEST
This incident affected: BLIK.