Status: PayU Europe
Scheduled technical break of mBank
Scheduled for Nov 24, 02:00 - 09:00 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 18, 2024 - 10:52 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 18, 2024 - 10:17 CET
Scheduled
We inform that a technical break is planned for 24.11.2024 (Sunday) between 02:00 am – 09:00am payments through mBank will not be possible in the specified time interval.
Posted Nov 18, 2024 - 10:15 CET
This scheduled maintenance affects: Banks PL (mBank).