Status: PayU Europe

Problems at BLIK

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 14:26 CET

Update

As of 2:20 PM problems have been mitigated by BLIK.
Posted Nov 03, 2025 - 14:25 CET

Investigating

On 03.11.2025 at 13:50 AM CET we have identified problems at BLIK.
Payments with BLIK are currently not available for PayU Europe integrations.

We are supporting the BLIK to handle this issue

We apologize for the inconvenience.
Posted Nov 03, 2025 - 14:03 CET
This incident affected: BLIK.