Status: PayU Europe

degradation at BLIK

Incident Report for PayU Europe

Resolved

Blik is fully operational. The issue lasted from 19:30 to 22:07.
Posted May 17, 2025 - 22:15 CEST

Monitoring

The incident has been resolved on Blik side.
Posted May 17, 2025 - 22:11 CEST

Update

We are continuing to investigate this issue with BLIK.
Posted May 17, 2025 - 21:59 CEST

Update

We are continuing to investigate this issue with BLIK.
Posted May 17, 2025 - 21:19 CEST

Update

We are continuing to investigate this issue.
Posted May 17, 2025 - 20:51 CEST

Investigating

on 17.05.2025 from 7:30 PM CEST we have identified a problem at BLIK. Payments with BLIK are degraded for PayU Europe integrations. We are monitoring the situation.
Posted May 17, 2025 - 20:26 CEST
This incident affected: BLIK.