Status: PayU Europe

PayU system degradation

Incident Report for PayU Europe

Resolved

today, on 28.02.2025 from 09:30 AM CET we were facing a technical problem.

Please expect the following:
notifications were delayed
authorisations were delayed

Issue was fixed at 10:03 CET.

We apologize for the inconvenience.
Posted Feb 28, 2025 - 09:30 CET