Status: PayU Europe

Degradation at BLIK

Incident Report for PayU Europe

Resolved

BLIK is back to normal as of 15:05
Posted Dec 06, 2025 - 16:50 CET

Monitoring

Due to problems at one of the major banks, the BLIK conversion service has been degraded since 13:03 CET.
Posted Dec 06, 2025 - 14:46 CET
This incident affected: BLIK.