Status: PayU Europe
Problem at BLIK
Incident Report for PayU Europe
Resolved
This incident has been resolved.
Posted Nov 16, 2024 - 13:10 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 16, 2024 - 13:10 CET
Identified
on 16.11.2024 at 11:50 AM CET we have identified a problem at BLIK. Payments with BLIK are currently not available for PayU Europe integrations.

We are supporting BLIK to handle this issue
Posted Nov 16, 2024 - 12:09 CET
This incident affected: BLIK.