Status: PayU Europe

PayU system performance degradation

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 11:50 CET

Monitoring

Attack was mitigated as of 11:17. We are still closely monitoring situation.
Posted Feb 03, 2026 - 11:43 CET

Identified

From 11:03 CET we are experiencing a DDoS attack affecting our infrastructure. Our engineering team is actively implementing mitigation measures to restore full service. We apologize for any connectivity issues you may be experiencing.

Please expect the following:
customers may not able to use payment methods (provided by PayU Europe),
customers may not able to check their payment status on the PayU page,
you may not able to log in to the PayU Management Panel,
conversion rate on transactions might be lower than usual.
Posted Feb 03, 2026 - 11:28 CET
This incident affected: Platform availability.