Status: PayU Europe
Card Issue
Incident Report for PayU Europe
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 11:33 CEST
Investigating
today 12.04.2024 from 10:26 to 10:35 we faced a failure of payments with Mastercard and Visa. As a result, payments by means of VISA and Mastercard were not possible. All payments work properly now.
Posted Apr 12, 2024 - 11:31 CEST
This incident affected: Cards.