Status: PayU Europe

Fixed issue with BLIK

Incident Report for PayU Europe

Resolved

today, on 28.03.2024 from 01:08 to 01:37 AM CET we faced a problem with BLIK. Payments with BLIK were temporarily not available for PayU Europe integrations, but it is back to normal now.

We apologize for any inconvenience.
Posted Mar 28, 2024 - 11:50 CET
This incident affected: BLIK.