Status: PayU Europe
PayU system failure
Incident Report for PayU Europe
Resolved
This incident has been resolved.
Posted Feb 08, 2024 - 10:09 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 08, 2024 - 10:09 CET
Investigating
today, on 08.02.2024 from 10:01 AM CET we are facing a major technical problem.
Please expect the following:

customers are not able to use payment methods (provided by PayU Europe),

customers are not able to check their payment status on the PayU page,

you are not able to log in to the PayU Management Panel.

We have immediately started working on resolving the issue

We apologise for the inconvenience.
Posted Feb 08, 2024 - 10:01 CET
This incident affected: Platform availability, Notifications, and Merchant Panel.