Status: PayU Europe
Total platform outage
Incident Report for PayU Europe
Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 14:01 CEST
Investigating
We are having total outage of the platform. We are investigating.
Posted Sep 02, 2024 - 13:37 CEST
This incident affected: Platform availability, Cards, BLIK, Notifications, and Merchant Panel.