Status: PayU Europe

delayed Delivery of Notifications

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 14:09 CET

Investigating

We are currently experiencing delays in the delivery of notifications. We are working to restore normal delivery times.
Posted Dec 15, 2025 - 14:00 CET
This incident affected: Notifications.