Status: PayU Europe

Degradation at BLIK

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Jul 21, 2025 - 16:57 CEST

Investigating

on 21.07.2025 from 16:36CEST there is a problem at BLIK side. Payments with BLIK are degraded for PayU Europe integrations. We are monitoring the situation.
Posted Jul 21, 2025 - 16:56 CEST
This incident affected: BLIK.