Status: PayU Europe
Card Payments failure
Incident Report for PayU Europe
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 14:05 CET
Update
today (21.03.2024) from 13:52:26 to 13:57:06 we faced a failure of payments with Cards. As a result, payments by means of VISA and Mastercard were not possible. All payments work properly now. We apologize for any inconvenience.
Posted Mar 21, 2024 - 14:04 CET
Investigating
We are facing problems with card processor starting 13:53
Posted Mar 21, 2024 - 13:57 CET
This incident affected: Cards.