Status: PayU Europe

ApplePay (VISA) issue

Incident Report for PayU Europe

Resolved

Problem was resolved at 19:01 (CEST) by ApplePay
Posted May 16, 2025 - 19:10 CEST

Monitoring

The problem is connected to the global ApplePay outage
Posted May 16, 2025 - 18:40 CEST

Identified

today (16.05.2025) since 17:18 (CEST) we are facing a degradation of ApplePay payments with VISA cards.
Posted May 16, 2025 - 18:25 CEST