Status: PayU Europe

degradation at BLIK

Incident Report for PayU Europe

Resolved

The problem was solved at 1 9:03 CEST.
Posted Jul 21, 2026 - 19:13 CEST

Identified

Blik has confirmed problem on their end. Blik team is working on resolving the issue.
Posted Jul 21, 2026 - 18:32 CEST

Investigating

Since 17:45, we have been experiencing degraded performance affecting BLIK transactions. As a result, a portion of transactions is not being authorized. We are actively investigating the issue together with the BLIK team and are working to restore full service. Further updates will be provided as soon as more information becomes available.
Posted Jul 21, 2026 - 18:06 CEST
This incident affected: BLIK.