Status: PayU Europe

Problems at BLIK

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 23:44 CEST

Investigating

We are observing degradation of authorization rate on Blik payment methods. We are currently investigating the issue with provider.
Posted Apr 08, 2026 - 23:37 CEST
This incident affected: BLIK.