Status: PayU Europe

PayPo outage

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 11:40 CET

Investigating

We regret to inform you that we are currently experiencing a service disruption affecting PayPo. Partner's technical teams are actively working to resolve the issue as quickly as possible.
Posted Mar 23, 2026 - 11:34 CET