Status: PayU Europe

Scheduled technical break of Credit Agricole Installments

Scheduled for Apr 6, 01:00 - 05:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 31, 2025 - 11:34 CEST

Scheduled

We inform that a technical break is planned for Credit Agricole Installments on 06.04.2025, from 01:00 AM to 05:00 AM and payments through Credit Agricole Installments will not be possible in the specified time interval.
Posted Mar 31, 2025 - 11:07 CEST
This scheduled maintenance affects: Banks PL (Credit Agricole).