Status: PayU Europe

BLIK Reduced Payment Conversion

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 18:45 CET

Identified

We are currently observing a reduced conversion rate on BLIK payment processing channel .

Transactions may be affected by lower success rates.

Our team is actively monitoring the situation and supporting BLIK to handle this issue.

We will provide an update as soon as more information is available or the situation is resolved.

We apologize for the inconvenience.
Posted Nov 03, 2025 - 15:36 CET
This incident affected: BLIK.