Status: PayU Europe

delayed Delivery of Notifications

Incident Report for PayU Europe

Resolved

The issue causing delayed notification delivery has been identified and resolved. Notification services have returned to normal operation.
Thank you for your patience.
Posted Dec 10, 2025 - 19:24 CET

Investigating

We are currently experiencing delays in the delivery of notifications. We are working to restore normal delivery times.
Posted Dec 10, 2025 - 19:09 CET
This incident affected: Notifications.