Status: PayU Europe

System degradation - DDOS

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 23:04 CET

Investigating

There is ongoing DDOS attack on PayU starting 22:00 CET. Some payment methods might be degraded. Impact is minimal.
Posted Mar 04, 2026 - 22:47 CET