Status: PayU Europe
VISA 3DS Service Issue
Incident Report for PayU Europe
Resolved
This incident has been resolved.
Posted Jun 08, 2024 - 18:54 CEST
Monitoring
At 18:21 (CEST) fix has been implemented and we are monitoring the results.
Posted Jun 08, 2024 - 18:48 CEST
Update
VISA is continuing to work on a fix for this issue.
Posted Jun 08, 2024 - 17:57 CEST
Identified
VISA has an ongoing issue of 3DS service

Incident start date: [2024-06-08 17:13 CEST]

If the situation changes, a status update will be sent.
Posted Jun 08, 2024 - 17:56 CEST
This incident affected: Cards.