Status: PayU Europe

PayU system failure

Incident Report for PayU Europe

Resolved

This incident has been resolved.
Posted Feb 28, 2026 - 12:42 CET

Update

We are continuing to monitor for any further issues.
Posted Feb 28, 2026 - 12:15 CET

Update

We are continuing to monitor for any further issues.
Posted Feb 28, 2026 - 12:12 CET

Monitoring

As of 11:57 the transactions are being accepted. System is working properly right now. We are monitoring the situation
Posted Feb 28, 2026 - 12:05 CET

Update

The problem is not yet resolved.
Posted Feb 28, 2026 - 12:01 CET

Update

Situation is getting back to stable state. We are observing the situation.
Posted Feb 28, 2026 - 11:59 CET

Update

We are continuing to investigate this issue.
Posted Feb 28, 2026 - 11:47 CET

Investigating

today, on 28.02.2026 from 11:29 AM/PM CEST we are facing a major technical problem.
Please expect the following:

customers are not able to use payment methods (provided by PayU Europe),

customers are not able to check their payment status on the PayU page,

you are not able to log in to the PayU Management Panel.

We have immediately started working on resolving the issue, and we expect to fix the problem by HH:MM CEST.

We apologize for the inconvenience.
Posted Feb 28, 2026 - 11:47 CET
This incident affected: Platform availability, Cards, and BLIK.