Status: PayU Europe

Mastercard authorization degradation.

Incident Report for PayU Europe

Resolved

The problem has been resolved on Mastercard side.
Posted Mar 09, 2025 - 10:39 CET

Investigating

Since 8:15 CET we are experiencing degradation in Mastercard payments authorizations. Some Mastercard transactions are not being authorized. We have notified Mastercard about the problem.
Posted Mar 09, 2025 - 10:17 CET
This incident affected: Cards.