Status: PayU Europe

Problems with the Management Panel.

Incident Report for PayU Europe

Resolved

Service was fully restored at 22:30 (CET)
Posted Feb 19, 2026 - 11:11 CET

Update

The issue is currently being resolved - the the amount of missing data in the search results is gradually decreasing.
Posted Feb 18, 2026 - 14:34 CET

Investigating

Today, 18.02.2026, you may experience issues when searching for transactions in the PayU Management Panel. We are currently working to resolve the problem as quickly as possible.

We apologize for the inconvenience.
Posted Feb 18, 2026 - 09:36 CET
This incident affected: Merchant Panel.