We are continuing to monitor for any further issues.
Posted Feb 28, 2026 - 21:20 CET
Update
We are continuing to monitor for any further issues.
Posted Feb 28, 2026 - 21:06 CET
Monitoring
The transactional processing is restored now. Merchant panel is disable for safety reason at the moment. We will enable it once the attack is over.
Posted Feb 28, 2026 - 21:06 CET
Update
We are continuing to investigate this issue.
Posted Feb 28, 2026 - 20:56 CET
Update
We are experiencing DDOS attack ant the moment. We are working to limit the impact.
Posted Feb 28, 2026 - 20:42 CET
Update
We are continuing to investigate this issue.
Posted Feb 28, 2026 - 20:28 CET
Update
We are continuing to investigate this issue.
Posted Feb 28, 2026 - 20:25 CET
Investigating
We were experiencing an unexpected system performance degradation impacting our payment services since 7:54 PM. This might result in delayed or failed payment transactions for some users. Our engineering teams are actively investigating the root cause.
Posted Feb 28, 2026 - 20:21 CET
This incident affected: Platform availability and Merchant Panel.