Status: PayU Europe

System degradation

Incident Report for PayU Europe

Resolved

The problem was resolved at 11:29 CET. Due to nature of the attack there are still some geographical limitation in accessing Merchant Panel.
Posted Mar 06, 2026 - 11:42 CET

Investigating

since 11:19 CET we were suffering platform degradation due to DDOS attack,
Posted Mar 06, 2026 - 11:29 CET
This incident affected: Platform availability and Merchant Panel.